How do I update my API version to support 3DS2?

The Adyen native 3DS2 integration requires one of the latest versions of our APIs for it to work.

If you are using our Classic API (with or without client-side encryption) you will need to upgrade to at least version 40 (e.g. https://pal-test.adyen.com/pal/servlet/Payment/v40/authorise).

If you are using our Checkout API (with or without Secured Fields) you will need to upgrade to at least version 41 (e.g. https://checkout-test.adyen.com/v41/payments).

Our newer API endpoints are backward compatible with older versions of the endpoint, so you can expect all current functionalities you are using to continue to be supported.

For more information contact Support. Submit a request

Articles in this section

See more