There's a message saying secureFields object invalid

Cause

API keys mismatching between your Magento 2 installation and the web service user in Adyen Customer Area.

Solution

  • Regenerate the api key and flush cache in Magento.
  • If you are in LIVE make sure that the live endpoint prefix is correct.
  • Log into the Adyen customer area and check in the web service user that the Client-Side Encryption library is green. If it is not green then change it to a different version and see if this resolves the issue.
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